Minimum Browser Requirements

NC Finance Connect supports the following browser versions:

  • Internet Explorer (IE): ver. 11
  • Edge: ver. 12
  • Firefox: ver. 28
  • Chrome: ver. 29
  • Safari: ver. 9
  • Opera: ver. 17
  • iOS Safari: ver. 9.2
  • Opera Mini: all versions
  • Android Browser: ver. 4.4
  • Blackberry Browser: ver. 10
  • Opera Mobile: ver. 12.1
  • Chrome for Android: ver. 51
  • Firefox for Android: ver. 47
  • IE Mobile: ver. 11
  • UC Browser for Android: Not Supported
  • Samsung Internet: ver. 4

If you access NC Finance Connect from an older version of any of these browsers, the site may not be fully functional.

Advanced forms